Järjestelmävaatimukset

Kehittäjille › Järjestelmävaatimukset

Ohjelmisto vaatii toimiakseen LAMP-yhteensopivan kotisivutilan. Tämä tarkoittaa sitä, että verkkokauppiaan on ostettava netistä LAMP-yhteensopiva webhotellipalvelu, joka maksaa yleensä 10-15 €/kk (ALV 0 %). Webhotellipalveluun kuuluu yleensä kotisivutila, sähköpostipalvelu, verkkotunnus ja tietokanta. Nämä kaikki ovat välttämättömiä ohjelmiston toiminnan kannalta.

Järjestelmävaatimukset koskevat ainoastaan kotisivutilaa, johon ohjelmisto asennetaan. Sen sijaan ohjelmiston asentajalla, verkkokauppiaalla ja verkkokaupan asiakkailla voi olla käytössään mikä tahansa käyttöjärjestelmä ja verkkoselain.

Pakolliset järjestelmävaatimukset

  • Linux-käyttöjärjestelmä
  • Apache-palvelinohjelmisto (tai LiteSpeed)
  • MySQL-tietokanta 5.1–5.7 (tai MariaDB)
  • PHP-tulkki 5.6–7.3, jossa ionCube-laajennus
  • Verkkotunnus
PHP-tulkin harvinaisimmista laajennuksista pakollisia ovat gd, ioncube_loader, json, mbstring, xmlwriter ja zip, joista ioncube_loader on ehdottoman pakollinen - jokin muu puute ainoastaan rajoittaa ohjelmiston ominaisuuksia.

Suositeltavat järjestelmävaatimukset

  • Apache-palvelinohjelmiston mod_rewrite-laajennus
  • Apache-palvelinohjelmiston mod_headers-laajennus
  • Tietoliikenteen salaaminen (https://)
Scroll to Top